Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bricked Huawei Y541-U02
#1
Hi,

I have a Huawei Y541-U02 which is stuck on the Huawei logo with the error message 'Check download state last download may not be complete'.

The only way I get get it to restart is by removing the battery and re-inserting it.

I cannot enter recovery mode - tried Vol Up + Down + Power, Vol Down + Power and every time it just takes me to the Huawei logo screen.

Tried to reflash using Spreadtrum Tool - the only way I could get any response is by using Factory Download Tool (not with either Research Tool and Upgrade Tool) and having the Vol Down + Power pressed while plugging the phone to the USB port. When I do this, Spreadtrum Factory Download Tool downloads all the files and reports successful completion. However, when I power it on, again I get the same error message and logo screen.

Upon doing more checking I found out that this is a problem with corrupted eMMC in the phone.

Would appreciate if anyone can provide any suggestions or comments before I decide to chuck this phone in the rubbish bin.

Many thanks.
Add Thank You Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Huawei ALL MTK SP FlashTools Firmware Collection android master 3 11,836 09-02-2019, 04:39 PM
Last Post: tatia
Thumbs Up please guys send me huawei psmart fig lx 1 scatter file thomas 0 1,225 02-08-2019, 12:20 PM
Last Post: thomas

Forum Jump:


Users browsing this thread: 1 Guest(s)